SpellBound ~ Spellchecker For Firefox

SpellBound is the one Firefox extension that is a must have for me! SpellBound was developed by Robert Strong who is on the development team for Firefox 2.0 due out late this summer. Now in Firefox 2.0 inline (spell as you type) will be an included feature. But you can have it now with SpellBound.

So, why SpellBound?

  • It is a Spellchecker for your browser
  • It works on any site with text area such as web forms, forums (mozillaZine, Delphi Forums), web-based e-mails (Hotmail, G-Mail, Yahoo!Mail), and even Blogs!

There two different versions of Spellbound, Spellbound, the ‘classic’ version and the Developmental Version.

The ‘classic’ version is for folks running builds older than Firefox 1.5 (it will work with some effort on Firefox 1,5 and above, see entry Installing Spellbound on FF 1.5.0.*). This version adds a ‘Check Spelling…’ command to your context (right-click) menu and you can add the optional icon on your toolbar.

The developmental version is design to be used with Firefox 1.5.0.* builds and is a preview of what will be standard in Firefox 2.0. The developmental version is so much easier to install and doesn’t have migration (moving to a newer version of FF) issues as does the classic version. The biggest and best feature is the inline or spell as you type feature. Very similar to the inline spell checking you see in MS Office, OpenOffice.org, MS Outlook, Thunderbird, etc. It will place a red underline on any misspelled word. However, instead of right-clicking you need to CTRL+Left-Click to access the SpellBound context menu. From there you can pick from a list of suggestions, add the word to your dictionary or ignore the word.

  SpellBound (Classic) SpellBound Developmental
Firefox Builds 1.0.* (can work with 1.5.0.* but not recommended)
1.5.0.* or newer ONLY
Inline Spellcheck NO
YES
Spellcheck Icon &
via Context Menu
YES

YES

Migration Issues Yes, dictionary needs to be reinstalled on each upgrade
and other issues with 1.5.0.* builds
No re-installation needed after upgrades

Installation Instructions

  1. Open a new tab
  2. Drag this link into the new tab: http://exchangecode.com/spellbound/downloads/spellbound-dev_20060108.xpi
  3. After the extensions has installed close and restart Firefox
  4. While in a text-area, right click and select ‘Check Spelling…” from the menu.
  5. On the bottom left of the ‘Check Spelling’ window, select English/United States ‘Language:’ drop down box
  6. Click ‘Close’

Note to MAC users, there appears to be an issue with the SpellBound Dictionaries with the Firefox 1.5.0.* builds. You will not be able to use SpellBound. However, this problem should be resolved with the release of FF 2.0 later this summer.


Comments

SpellBound ~ Spellchecker For Firefox — 2 Comments

  1. Pingback: Installing Spellbound FF 1.5.0.X « FF Extension Guru’s Blog

  2. Pingback: [mck] » Spelling Firefox extensions

Leave a Reply