IE Tab +

Support for the ‘original’ IE Tab ended with Firefox 3.5 in June 2009. I believe it was through Go Firefox! I learned about IE Tab +. The extension not only supports Firefox 3.6 but also has an integrated version of AdBlock Plus that will work within the IE Tab.

IE Tab + works with Firefox 3.6 and 4.0 (32-bit only).

Update: 03/15/2011 IE Tab + (not to be confused with IE Tab Plus) supports Firefox 3.6 and newer


Comments

IE Tab + — 3 Comments

  1. “Posted on June 18, 2010 by The Guru
    IE Tab Plus works with Firefox 3.0, 3.5, 3.6 (3.7/4.0 support coming soon)”

    What would be the definition of “soon” as it relates to June 18, 2010?

    John <

Leave a Reply