Firefox 5 and Add-ons

It seems some extension developers did not take Mozilla seriously when the firm release date for Firefox 5 was announced about 2-months ago. As a result these developers have neglected to update their extensions (which will work in Firefox 5) to bump up the maximum supported version. It is important to understand Firefox 4.0 is no longer supported. However, there is no change to the core of Firefox 5.0, 6.0 or 7.0 so add-ons that are already working in Firefox 4.0 will work in these newer versions if forced.

The Add-on Compatibility Reporter extension will take care of this for you. Note: this extension requires two restarts initially. This add-on has also allowed Mozilla to reach-out to these extension developers during the Aurora and Beta cycles letting them know they need to update their extension compatibility.