JAVA Plugin Update/Blocking

Users should ensure sure they have the most recent versions of Java Runtime Environment (JRE) and Java Developers Kit (JDK) plugins (note not all users may be using these plug-ins). Due to an increasingly exploited voluntarily found in the older versions of JRE and JDK plugins Mozilla is actively blocking outdated versions of these plugins.

This vulnerability—present in the older versions of the JDK and JRE—is actively being exploited, and is a potential risk to users. To mitigate this risk, we have added affected versions of the Java plugin (Version 6 Update 32 and below as well as Version 7 Update 4 and below) to Firefox’s blocklist.

A pop-up will appear alerting the user the JRE and/or JDK plugins have been disabled and they need to restart their browser. Users can (at their own risk) reactivate the blocked/disabled plugins via the add-ons manager. Users can check these and the rest of their plugins via the Mozilla Plugin Check and Updates site.

Mozilla Add-ons Blog


Leave a Reply