Mozilla Blacklists Flash 18.0.0.203

If you updated your Flash Player Plugin last week to version 18.0.0.203, you will need to update again today in order to use Flash in Firefox. Mozilla has blocked the 18.0.0.203 version of Shockwave Flash which contained security fixes for 0-day vulnerabilities, but was found to contain vulnerabilities itself.

Adobe released version 18.0.0.209 ealier this morning which patched two vulnerabilities. To upgrade from within Firefox go to Tools > Add-ons then select Plugins on the left side. Above the list of plugins click the Check to see if your plugins are up to date link. A new tab will open with a screen similar to the one below.

fx flash 18

Click the Update Now button to go to Adobe’s site and download version 18.0.0.209. On the Adobe Flash Player site be sure to uncheck the Optional offer for McAfee Security Scan Plus in the middle panel before clicking the Install now button. Follow the prompts to complete the update the Flash Plugin which includes restarting Firefox.

There is more news about Flash today besides this update. Facebook CSO wants ‘End of Life Date’ for Flash