Animated GIF's & Profiles

It started simple enough, I was being asked on the CyberNet Forum why on my Tweaks Site I indicated the Pause/Restrict/Disable Animated GIFs tweak did NOT work with Firefox 3. The poster indicated it worked fine for them. I remember when I setup the tweak section I wrestled with this one as not all of the tweak worked with Firefox 3. Yes, you could press escape to stop the animated GIF. However the about:config tweak does not fully work with Firefox 3. The ‘once’ setting behaved the same as the ‘none’ setting. So, my decision was based on ‘all-or-nothing’, if the entire tweak did not work I would say it did not work with Firefox 3.

However to be fair I was going to revise the original entry with a note indicating the ‘once’ setting behaved the same as the ‘none’ setting. But first I opted to check this in Firefox 2, since I don’t really recall ever using that setting. So I closed Minefield and clicked the Bon Echo (nightly Firefox 2) shortcut on my Quick Launch Bar and was immediately Windows Vista threw the error: Firefox has stopped working. Checking for solutions… WTF? It hadn’t even launched yet much less was ‘working’. I tried a couple more times and had the same result. For whatever reason I tried a fourth time (as if it would magically start working) via the run box, but ended up with the same results.

At this point I knew one of two things must have happened. I had either downloaded a bad trunk build (very rare) the last time I updated Bon Echo or my Firefox 2 profile somehow got corrupted.  Simplest way to test this was to open the run box again and then drop the profile name off. The Firefox 2 profile manage came up, this was good sign that it was the profile not Firefox 2 that was damaged. I just created and launched with a ‘clean’ profile and Bon Echo worked.

Now the investigation began as to what had gone wrong. First I started off by opening up Windows Explore to my Firefox Profile folder. To do this in Vista open the run box and type in %APPDATA%\Mozilla\Firefox\Profiles\. The first thing I noticed was my Firefox 2 profile folder had been updated today, so it was reading and writing to the profile. I was kinda hoping it had not made the changes so I could see when the last time I had really used that profile was. Just for the heck of it I went ahead and explored the profile folder and noticed several files were dated today.  However there were also several more files dated 05/11/2008. Now I had a date to work with, but that was 2 1/2 weeks ago.

Well besides being a Sunday and Mother’s Day, I don’t recall much about May 11th. I looked thru my Blog entries to see if I could find anything that would jog my memory. Didn’t take long, as soon as I saw one of the posts from that day: Adventures in Safe Mode. I remember that day, I had done a forced install on the Google Toolbar and that caused Firefox 3 to crash upon start up. I had been attempting to get Firefox into safe mode:

So I hit WindowsKey + R and typed firefox.exe -safe-mode clicked OK and Firefox starts up in safe mode…sort of. Firefox 2 with my Firefox 2 profile started up in safe mode. Okay simple enough, I’ll just find where I have Firefox 3 installed and choose to run from that location. So this time I did WindowsKey + R and typed K:\Mozilla Firefox 3 Beta 5\firefox.exe -safe-mode and clicked OK. This time around Firefox 3 did start, but it was with my Firefox 2 profile (I kept forgetting it is set as my default).

Mystery solved! So apparently when I accidentally started Firefox 3 with my Firefox 2 profile that was the end of my Firefox 2 profile. I do recall reading somewhere a while back warning that new bookmark system (Places) in Firefox 3 would cause those profiles not to work in Firefox 2. This stresses the importance of keeping separate profiles as I described in one of my early posts (the dark days when I was still on Blogger) Multiple Profile Disorder!. I am not all that troubled that this profile doesn’t work anymore. After all, it had been 2 1/2 weeks since I had last gone into Firefox 2.

So, back to the whole reason I was trying to get into Firefox 2, to test the Animated GIF about:config tweaks. As it turns out in the newer builds of Firefox 2, the ‘once’ setting behaves the same as the ‘none’ setting. Okay, with that established I have changed the tweak listing to ‘YES’ for Firefox 3 and added a note to the post that the ‘once’ setting doesn’t work. Geesh, what should have taken a couple minutes ended up taking a couple hours when it was all said and done.